kgdb / kdb /debug_core · Maintained
Maintainers
- M Jason Wessel <jason.wessel@windriver.com>
- M Daniel Thompson <danielt@kernel.org>
- R Douglas Anderson <dianders@chromium.org>
Paths
- F
Documentation/process/debugging/kgdb.rst - F
drivers/misc/kgdbts.c - F
drivers/tty/serial/kgdboc.c - F
include/linux/kdb.h - F
include/linux/kgdb.h - F
kernel/debug/ - F
kernel/module/kdb.c
Last 30 days
Recent patches
Most-recent 16 patches in this subsystem on netdev, ordered by date desc.
-
STALE73d
[RFC PATCH 1/2] kernel/notifier: replace single-linked list with double-linked list for reverse traversal
2026-04-15 · <hidden> -
STALE138d
[PATCH 08/19] debug: debug_core: Migrate to register_console_force helper
2025-12-27 · Marcos Paulo de Souza <hidden> -
STALE138d
[PATCH 03/19] printk: Drop flags argument from console_is_usable
2025-12-27 · Marcos Paulo de Souza <hidden> -
STALE138d
[PATCH 02/19] printk: Introduce console_is_nbcon
2025-12-27 · Marcos Paulo de Souza <hidden> -
STALE138d
[PATCH 01/19] printk/nbcon: Use an enum to specify the required callback in console_is_usable()
2025-12-27 · Marcos Paulo de Souza <hidden> -
STALE1584d
[PATCH 6/6] treewide: remove check of list iterator against head past the loop body
2022-02-28 · Jakob Koschel <hidden> -
STALE2184d
[PATCH v2 15/16] treewide: Remove uninitialized_var() usage
2020-06-20 · Kees Cook <hidden> -
STALE2214d
[PATCH 09/10] treewide: Remove uninitialized_var() usage
2020-06-03 · Kees Cook <hidden> -
STALE2232d
[PATCH 20/23] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault
2020-05-21 · Christoph Hellwig <hch@lst.de> -
STALE2240d
[PATCH 17/20] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault
2020-05-19 · Christoph Hellwig <hch@lst.de> -
STALE2242d
[PATCH 16/18] maccess: rename probe_kernel_{read,write} to copy_{from,to}_kernel_nofault
2020-05-13 · Christoph Hellwig <hch@lst.de> -
STALE2450d
[PATCH] kernel: convert switch/case fallthrough comments to fallthrough;
2019-10-18 · Joe Perches <joe@perches.com> -
STALE4104d
[PATCH 16/25] include/linux: Use bool function return values of true/false not 1/0
2015-03-30 · Joe Perches <joe@perches.com> -
STALE5242d
[PATCHv3 3/3] KGDB: Allow registering multiple I/O ops.
2012-02-27 · Andrei Warkentin <hidden> -
STALE5844d
[PATCH RFC 4/4] kgdb: Quiesce IO back-end before rounding up secondary CPUs
2010-07-07 · Anton Vorontsov <hidden> -
STALE5980d
[PATCH] module param_call: fix potential NULL pointer dereference
2010-02-21 · Dongdong Deng <hidden>